Image
Image
Screenshots
First slide
First slide
First slide
First slide
Downloads
Minecraft 1.20.1
S Goblin Traders 1.9.2

Requires Framework

Minecraft 1.19.4
S Goblin Traders 1.8.2
Minecraft 1.19.3
S Goblin Traders 1.8.0
Minecraft 1.19.2
S Goblin Traders 1.8.0
Minecraft 1.20.1
S Goblin Traders 1.9.2

Requires Framework

Minecraft 1.19.4
S Goblin Traders 1.8.3

Requires Framework

Click "View All Files" below to find downloads for more Minecraft versions.

S = Stable

B = Beta

A = Alpha